Unplanned Authoring Outage Required for all Regions
Incident Report for Learnosity
Resolved
As of 03:00 UTC, we have observed all system to be performing as expected and are resolving this issue. We will continue to monitor our systems for a period of hours following resolution, should anything related occur.

Learnosity Support and Systems Engineering teams will follow up with a post mortem once we have completed root cause analysis and finalised any next steps or preventative measures required.

Please reach out if you have any questions or concerns.
Posted Jul 06, 2023 - 23:05 EDT
Monitoring
As of 00:50 UTC, newly created/updated content is fully available worldwide.

Learnosity Support and Systems Engineering teams are continuing to monitor the issue to ensure it has completely stabilised.
Posted Jul 06, 2023 - 21:51 EDT
Identified
As of 22:30 UTC, newly created/updated content is almost fully available worldwide. AWS regions us-west-2 (AMER OR), us-east-1 (AMER VA), and eu-west-1 (EMEA IE) are current. The ap-southeast-2 (APAC AU) region is still a somewhat behind and recovering.

Learnosity Support and Systems Engineering teams are continuing to work on the issue, and will follow on with an update and resolution as soon as possible.
Posted Jul 06, 2023 - 18:49 EDT
Monitoring
As of 21:00 UTC, we are continuing to work on this issue and will update this alert as new information becomes available.
Posted Jul 06, 2023 - 17:08 EDT
Investigating
As of 19:50 UTC, authoring of new content has been restored. A brief period will now follow during which any content newly authored since 19:50 UTC will gradually become available to all regions.

We will update this alert again when all regions are updated.

Learnosity Support and Systems Engineering teams will follow on with further updates and a resolution as soon as possible.
Posted Jul 06, 2023 - 15:54 EDT
Update
As of 19:25 UTC, Learnosity has begun its unplanned outage of authoring new content. We will update this alert when authoring creation/editing becomes available again.

Existing content will continue to be available to assessments and analytics, with no other APIs affected.

Learnosity Support and Systems Engineering teams will follow on with further updates and a resolution as soon as possible.
Posted Jul 06, 2023 - 15:24 EDT
Identified
Within an estimated thirty minutes, Learnosity will begin an unplanned outage of authoring new content as part of restoring the ability to create new item pools. Existing content and item pools are now, and will continue to remain, available to assessments and analytics.

This unplanned outage is expected to last less than sixty minutes and will only affect the creation and updating of new content. Once authoring of new content is restored, a brief span of degraded performance will follow during which new content will gradually become available to all regions.

No other APIs are affected.

Learnosity Support and Systems Engineering teams will follow up with further updates and a resolution as soon as possible.
Posted Jul 06, 2023 - 14:53 EDT
This incident affected: AMER || Authoring (Creating and saving of Items/Activities/Tags, Creating and saving of Tag Hierarchies (author site)), APAC || Authoring (Creating and saving of Items/Activities/Tags, Creating and saving of Tag Hierarchies (author site)), and EMEA || Authoring (Creating and saving of Items/Activities/Tags, Creating and saving of Tag Hierarchies (author site)).