Issue intermittently affecting capture of student responses in VA (US-EAST-1) - *.learnosity.com
Incident Report for Learnosity
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 05, 2018 - 12:45 EDT
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Sep 05, 2018 - 12:37 EDT
Monitoring
As of 16:15 UTC, Intermittent issues relating to Amazon SQS appears resolved, and processing of saves has returned to normal. AWS currently have an investigation open concerning increased error rates in the US-EAST-1 region.

https://status.aws.amazon.com/

Learnosity Support and Engineering teams will continue to actively monitor the situation, and follow up with any further detail as soon as possible
Posted 3 months ago. Sep 05, 2018 - 12:36 EDT
Update
As of 16:10 UTC, we have put in place a number of steps to mitigate the level of impact of this AWS SQS issue. Due to this, authoring and the initial load of the assessment APIs should no longer be affected.

While we continue to work on the core issue, users may see a higher incident of response save failures during this time. However, User driven saves (via Learnosity API UI buttons) will provide dialog options to retry saving, and programmatic saves (via .save() methods) will raise an errorListener for the application to handle in it's preferred manner.

Learnosity Support and Systems Engineering teams are actively investigating the issue, and will follow on with an update and resolution as soon as possible.
Posted 3 months ago. Sep 05, 2018 - 12:10 EDT
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Sep 05, 2018 - 15:30 EDT
Identified
As of 15:30 UTC, we've identified an issue relating to timeouts writing to an Amazon SQS queue. Due to the nature of the issue, it's also in some cases causing a slow load or failure to load of the Questions API.

Learnosity Support and Systems Engineering are working to put in place workarounds to mitigate the effect on authoring or initial loading of assessment delivery, and will follow on with an update and resolution as soon as possible.
Posted 3 months ago. Sep 05, 2018 - 11:30 EDT
Investigating
As of 14:45 UTC, We are currently experiencing an intermittent issue affecting capture of student responses in US-EAST-1 (VA), affecting those using items.learnosity.com, items-va.learnosity.com, questions.learnosity.com and questions-va.learnosity.com.

Learnosity Support and Systems Engineering teams are actively investigating the issue, and will follow on with an update and resolution as soon as possible.
Posted 3 months ago. Sep 05, 2018 - 10:45 EDT