Issue affecting dispatch of Firehose messages in us-east-1
Incident Report for Learnosity
Resolved
As of 21:06 UTC, we are have resolved the issue affecting dispatch of Firehose messages in us-east-1.

All services should be fully operational now.

Learnosity Support and Systems Engineering teams will follow up with a post mortem once we have completed root cause analysis and finalized any next steps or preventative measures required.

Please reach out if you have any questions or concerns.
Posted Dec 14, 2020 - 16:07 EST
Monitoring
As of 20:54 UTC, all systems are operational with minimal to no delays in session results for affected custoemrs.

Learnosity Support and Systems Engineering teams are continuing to monitor the issue, and will follow on with an update and resolution as soon as possible.
Posted Dec 14, 2020 - 15:59 EST
Update
As of 18:52 UTC, Firehose appears to be functioning normally.

We are continuing to investigate possible scoring delays affecting a small number of customers.

Learnosity Support and Systems Engineering teams are continuing to actively investigate the issue, and will follow on with an update and resolution as soon as possible.
Posted Dec 14, 2020 - 14:56 EST
Update
As of 19:00 UTC, we are still investigating delays affecting Firehose messages, slower response times for the Data and Reports APIs, affecting a small number of customers.

Learnosity Support and Systems Engineering teams are continuing to actively investigate the issue, and will follow on with an update and resolution as soon as possible.
Posted Dec 14, 2020 - 14:09 EST
Investigating
As of 18:00 UTC, we are investigating delays affecting Firehose Submission Responses messages affecting a small number of customers in us-east-1.

Learnosity Support and Systems Engineering teams are actively investigating the issue, and will follow on with an update and resolution as soon as possible.
Posted Dec 14, 2020 - 13:25 EST
This incident affected: USA || Analytics (Availability of session information) and USA || Data Centric (Firehose).