Browser bug in Chrome 61 affecting Formula questions and math editing
Incident Report for Learnosity
Resolved
We have rolled out patches across the Questions API and Question Editor API which have resolved this potential issue.

For all customers following our best practice of requesting a minor version you will already be using a fixed version - so there is nothing further to do.

For the few customers requesting a patch version of our API's you will need to manually update to the latest relevant patch version.
Posted about 1 year ago. Sep 13, 2017 - 20:41 EDT
Monitoring
On further investigation of this issue we have narrowed down the possible cases where it can occur and confirmed that it is a very small edge case that was caught by our automated testing. In the real world usage it has the potential to affect only 0.009% of items, and only when a very specific sequence of events that occurs only in the authoring environment.

We have investigated and are confident that this bug does not affect any students doing assessments.

Despite the limited scenarios where this can happen, the bug can cause a full browser crash, and so we will be patching multiple versions of the Questions API and Question Editor API - which will roll out on the 14th September AEST.

As per our SLA guidelines we recommend that all production environments point to a minor version - eg X.Y and do NOT point to a patch version X.Y.Z so that you will receive critical patches in a timely manner.
Posted about 1 year ago. Sep 13, 2017 - 02:41 EDT
Identified
Our engineering teams have identified the lines of code that are affected by the Chrome 61 bug and have developed a patch to work around this. We are currently testing this and preparing to release patches across all affected API versions to work around this problem for our customers.
Posted about 1 year ago. Sep 12, 2017 - 19:04 EDT
Investigating
Due to a browser bug affecting the latest Chrome 61 release (used by ~2% of Learnosity users of the assessment APIs), we are currently running tests to identify potential issues with formula question types and math editing performance.

This may include excess browser memory usage, which may, in extreme cases, cause some browsers to crash.

The potentially affected areas for users of this browser version are:

Math Formula Question Type in review mode, or validated view with correct answers shown (Question Editor API and Questions API)
Cloze Math Formula Question Type in review mode, or validated view with correct answers shown (Question Editor API and Questions API)
Editing of Math Content (Question Editor API)
Any assessments loaded with Mathquill as the default renderer. (Questions API)

Learnosity Support and Systems Engineering teams are actively investigating the issue, and will follow up with an update and resolution as soon as possible. For any further information or concerns, please contact Learnosity Support.
Posted about 1 year ago. Sep 12, 2017 - 11:55 EDT